NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2018-1999009 — october

HIGH

CVE-2018-1999009 is a high-severity (CVSS 8.1) Information Exposure vulnerability in october/october. A fix is available for october/october — see the affected versions and patch details below.

October CMS Local File Inclusion

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
1.30%1.83%2.36%2.89%1.8%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘october/october

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

October CMS version prior to Build 437 contains a Local File Inclusion vulnerability in modules/system/traits/ViewMaker.php (makeFileContents function) that can result in Sensitive information disclosure and remote code execution. This attack appear to be exploitable remotely if the /backend path is accessible. This vulnerability appears to have been fixed in Build 437.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistoctober/octoberall versions1.0.437composer require october/october:^1.0.437

Affected Products

1 product · 1 configurations
Application
octoberoctobercms
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/october, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update october/october to 1.0.437 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1999009 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

October CMS version prior to Build 437 contains a Local File Inclusion vulnerability in [modules/system/traits/ViewMaker.php](https://github.com/octobercms/october/blob/v1.0.436/modules/system/traits/ViewMaker.php#L244) (makeFileContents function) that can result in Sensitive information disclosure and remote code execution. This attack appear to be exploitable remotely if the /backend path is accessible. This vulnerability appears to have been fixed in Build 437.
O3 Security · Impact-Aware SCA

Is CVE-2018-1999009 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-1999009: october RCE — Fixed in 1.0.437