CVE-2018-19789 is a medium-severity (CVSS 5.3) Unrestricted File Upload vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Path Disclosure
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/form🐘symfony/form+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9, and 4.2.x before 4.2.1. When using the scalar type hint string in a setter method (e.g. setName(string $name)) of a class that's the data_class of a form, and when a file upload is submitted to the corresponding field instead of a normal text input, then UploadedFile::__toString() is called which will then return and disclose the path of the uploaded file. If combined with a local file inclusion issue in certain circumstances this could escalate it to a Remote Code Execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.7.0&&< 2.7.50 | 2.7.50composer require symfony/symfony:^2.7.50 |
| 🐘Packagist | symfony/symfony | ≥ 2.8.0&&< 2.8.49 | 2.8.49composer require symfony/symfony:^2.8.49 |
| 🐘Packagist | symfony/symfony | ≥ 3.0.0&&< 3.4.20 | 3.4.20composer require symfony/symfony:^3.4.20 |
| 🐘Packagist | symfony/symfony | ≥ 4.0.0&&< 4.0.15 | 4.0.15composer require symfony/symfony:^4.0.15 |
| 🐘Packagist | symfony/symfony | ≥ 4.1.0&&< 4.1.9 | 4.1.9composer require symfony/symfony:^4.1.9 |
| 🐘Packagist | symfony/symfony | ≥ 4.2.0&&< 4.2.1 | 4.2.1composer require symfony/symfony:^4.2.1 |
Affected Products
debian linuxdebiansymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.7.50 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19789 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is CVE-2018-19789 in your dependencies?
Find it across Packagist, including transitive dependencies.