NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-19280 — centreon

MEDIUMFix: centreon/centreon-archived#6626

CVE-2018-19280 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in centreon/centreon. A fix is available for centreon/centreon — see the affected versions and patch details below.

Centreon XSS Vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.1%0.9%Jun 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘centreon/centreon

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Centreon 3.4.x (fixed in Centreon 18.10.0) has XSS via the resource name or macro expression of a poller macro.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcentreon/centreon≥ 3.4.0&&< 18.10.018.10.0composer require centreon/centreon:^18.10.0

Affected Products

1 product · 1 configurations
Application
centreoncentreon
≥ 3.4.0 && ≤ 3.4.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for centreon/centreon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update centreon/centreon to 18.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19280 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Centreon 3.4.x (fixed in Centreon 18.10.0) has XSS via the resource name or macro expression of a poller macro.
O3 Security · Impact-Aware SCA

Is CVE-2018-19280 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-19280: centreon XSS — Fixed in 18.10.0