CVE-2018-19271 is a high-severity (CVSS 8.8) SQL Injection vulnerability in centreon/centreon. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for centreon/centreon — see the affected versions and patch details below.
Centreon SQL Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
centreon/centreon🐘centreon/centreonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Centreon 3.4.x (fixed in Centreon 18.10.0 and Centreon web 2.8.28) allows SQL Injection via the main.php searchH parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | centreon/centreon | ≥ 18.0.0&&< 18.10.0 | 18.10.0composer require centreon/centreon:^18.10.0 |
| 🐘Packagist | centreon/centreon | all versions | 2.8.28composer require centreon/centreon:^2.8.28 |
Affected Products
centreoncentreonResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for centreon/centreon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update centreon/centreon to 18.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19271 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2018-19271 in your dependencies?
Find it across Packagist, including transitive dependencies.