NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-17605 — asset-pipeline

HIGHFix: bertramdev/asset-pipeline@a29533c

CVE-2018-17605 is a high-severity (CVSS 7.5) Path Traversal vulnerability in org.grails.plugins:asset-pipeline. A fix is available for org.grails.plugins:asset-pipeline — see the affected versions and patch details below.

Asset Pipeline plugin for Grails vulnerable to Path Traversal

Also known asGHSA-g7wm-22m6-5774
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.90%1.81%2.71%0.4%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.grails.plugins:asset-pipeline

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the Asset Pipeline plugin before 3.0.4 for Grails. An attacker can perform directory traversal via a crafted request when a servlet-based application is executed in Jetty, because there is a classloader vulnerability that can allow a reverse file traversal route in AssetPipelineFilter.groovy or AssetPipelineFilterCore.groovy.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.grails.plugins:asset-pipelineall versions3.0.4org.grails.plugins:asset-pipeline:3.0.4

Affected Products

1 product · 1 configurations
Application
asset-pipelineasset_pipeline_project
< 3.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.grails.plugins:asset-pipeline, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.grails.plugins:asset-pipeline to 3.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-17605 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

An issue was discovered in the Asset Pipeline plugin before 3.0.4 for Grails. An attacker can perform directory traversal via a crafted request when a servlet-based application is executed in Jetty, because there is a classloader vulnerability that can allow a reverse file traversal route in AssetPipelineFilter.groovy or AssetPipelineFilterCore.groovy.
O3 Security · Impact-Aware SCA

Is CVE-2018-17605 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-17605: asset-pipeline — Fixed in 3.0.4