CVE-2018-16637 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in evolutioncms/evolution. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for evolutioncms/evolution — see the affected versions and patch details below.
Evolution CMS Stored Cross-site Scripting (XSS)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
evolutioncms/evolutionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Evolution CMS 1.4.x prior to 1.4.6 allows XSS via the page weblink title parameter to the manager/ URI.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | evolutioncms/evolution | ≥ 1.4&&< 1.4.6 | 1.4.6composer require evolutioncms/evolution:^1.4.6 |
Affected Products
evolution cmsmodxResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for evolutioncms/evolution, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update evolutioncms/evolution to 1.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-16637 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2018-16637 in your dependencies?
Find it across Packagist, including transitive dependencies.