CVE-2018-16483 — express-cart
HIGHCVE-2018-16483 is a high-severity (CVSS 8.8) CWE-290 vulnerability in express-cart. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for express-cart — see the affected versions and patch details below.
Authentication Bypass by Spoofing in express-cart
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
express-cartnpmDescription
A deficiency in the access control in module express-cart <=1.1.5 allows unprivileged users to add new users to the application as administrators.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | express-cart | all versions | 1.1.6npm install express-cart@1.1.6 |
Affected Products
express-cartexpress-cart_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for express-cart, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update express-cart to 1.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-16483 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2018-16483 in your dependencies?
Find it across npm, including transitive dependencies.