NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2018-12457 — express-cart

HIGHFix: mrvautin/expressCart@baccaae

CVE-2018-12457 is a high-severity (CVSS 8.8) CWE-732 vulnerability in express-cart. A fix is available for express-cart — see the affected versions and patch details below.

express-cart allows any user to create an admin user

Also known asGHSA-hr89-w7p6-pjmq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.02%0.82%1.62%2.42%0.5%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
express-cartnpm
168downloads / week

Description

expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmexpress-cartall versions1.1.6npm install express-cart@1.1.6

Affected Products

1 product · 1 configurations
Application
expresscartexpresscart_project
< 1.1.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for express-cart, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update express-cart to 1.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-12457 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.
O3 Security · Impact-Aware SCA

Is CVE-2018-12457 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-12457: express-cart — Fixed in 1.1.6