CVE-2018-14774 is a high-severity (CVSS 7.2) Improper Input Validation vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Host Header Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfonyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in HttpKernel in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. When using HttpCache, the values of the X-Forwarded-Host headers are implicitly set as trusted while this should be forbidden, leading to potential host header injection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.7.0&&< 2.7.49 | 2.7.49composer require symfony/symfony:^2.7.49 |
| 🐘Packagist | symfony/symfony | ≥ 2.8.0&&< 2.8.44 | 2.8.44composer require symfony/symfony:^2.8.44 |
| 🐘Packagist | symfony/symfony | ≥ 3.3.0&&< 3.3.18 | 3.3.18composer require symfony/symfony:^3.3.18 |
| 🐘Packagist | symfony/symfony | ≥ 3.4.0&&< 3.4.14 | 3.4.14composer require symfony/symfony:^3.4.14 |
| 🐘Packagist | symfony/symfony | ≥ 4.0.0&&< 4.0.14 | 4.0.14composer require symfony/symfony:^4.0.14 |
| 🐘Packagist | symfony/symfony | ≥ 4.1.0&&< 4.1.3 | 4.1.3composer require symfony/symfony:^4.1.3 |
Affected Products
symfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.7.49 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-14774 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-14774 in your dependencies?
Find it across Packagist, including transitive dependencies.