NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2018-14505 — mitmproxy

HIGHFix: mitmproxy/mitmproxy#3243

CVE-2018-14505 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in mitmproxy. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mitmproxy — see the affected versions and patch details below.

Mitmweb in mitmproxy allows DNS Rebinding attacks

Also known asGHSA-6m53-c78q-7qmgPYSEC-2018-56
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%1.42%2.83%4.25%0.3%3.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mitmproxy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

mitmweb in mitmproxy before v4.0.4 allows DNS Rebinding attacks, related to tools/web/app.py.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImitmproxyall versions4.0.4pip install --upgrade 'mitmproxy==4.0.4'

Affected Products

1 product · 1 configurations
Application
mitmproxymitmproxy
1 version
4.0.3
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mitmproxy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mitmproxy to 4.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-14505 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

mitmweb in mitmproxy before v4.0.4 allows DNS Rebinding attacks, related to tools/web/app.py.
O3 Security · Impact-Aware SCA

Is CVE-2018-14505 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-14505: mitmproxy — Fixed in 4.0.4