NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-13055 — mantisbt

MEDIUMFix: mantisbt/mantisbt@4efac90

CVE-2018-13055 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mantisbt/mantisbt. A fix is available for mantisbt/mantisbt — see the affected versions and patch details below.

MantisBT allows XSS via View Filters page

Also known asGHSA-mjp7-97w4-jwhc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.67%1.34%2.02%0.3%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘mantisbt/mantisbt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site scripting (XSS) vulnerability in the View Filters page (view_filters_page.php) in MantisBT 2.1.0 through 2.15.0 allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted PATH_INFO.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmantisbt/mantisbt≥ 2.1.0&&< 2.15.12.15.1composer require mantisbt/mantisbt:^2.15.1

Affected Products

1 product · 1 configurations
Application
mantisbtmantisbt
≥ 2.1.0 && ≤ 2.15.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mantisbt/mantisbt to 2.15.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-13055 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A cross-site scripting (XSS) vulnerability in the View Filters page (view_filters_page.php) in MantisBT 2.1.0 through 2.15.0 allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted PATH_INFO.
O3 Security · Impact-Aware SCA

Is CVE-2018-13055 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-13055: mantisbt RCE — Fixed in 2.15.1