NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2018-12291 — matrix-synapse

HIGHFix: matrix-org/synapse#3371

CVE-2018-12291 is a high-severity (CVSS 7.5) vulnerability in matrix-synapse. A fix is available for matrix-synapse — see the affected versions and patch details below.

Matrix Synapse Security Filtering Flaw

Also known asGHSA-v8wm-g9f2-xjv4PYSEC-2026-664
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk-0.03%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.77%1.55%2.32%0.2%1.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍matrix-synapse

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The on_get_missing_events function in handlers/federation.py in Matrix Synapse before 0.31.1 has a security bug in the get_missing_events federation API where event visibility rules were not applied correctly.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImatrix-synapseall versions0.31.1pip install --upgrade 'matrix-synapse==0.31.1'

Affected Products

1 product · 1 configurations
Application
synapsematrix
< 0.31.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matrix-synapse, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update matrix-synapse to 0.31.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-12291 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The on_get_missing_events function in handlers/federation.py in Matrix Synapse before 0.31.1 has a security bug in the get_missing_events federation API where event visibility rules were not applied correctly.
O3 Security · Impact-Aware SCA

Is CVE-2018-12291 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-12291: matrix-synapse — Fixed in 0.31.1