CVE-2018-12071 is a critical-severity (CVSS 9.8) CWE-384 vulnerability in codeigniter/framework. A fix is available for codeigniter/framework — see the affected versions and patch details below.
CodeIgniter Session Fixation Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
codeigniter/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | codeigniter/framework | all versions | 3.1.10composer require codeigniter/framework:^3.1.10 |
Affected Products
codeignitercodeigniterDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for codeigniter/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update codeigniter/framework to 3.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-12071 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2018-12071 in your dependencies?
Find it across Packagist, including transitive dependencies.