CVE-2014-8684 is a critical-severity (CVSS 9.8) CWE-310 vulnerability in codeigniter/framework. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for codeigniter/framework — see the affected versions and patch details below.
CodeIgniter and Kohana vulnerable to PHP Object Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
codeigniter/framework🐘kohana/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | codeigniter/framework | all versions | 3.0.0composer require codeigniter/framework:^3.0.0 |
| 🐘Packagist | kohana/core | all versions | 3.3.3composer require kohana/core:^3.3.3 |
Affected Products
codeignitercodeigniterkohanakohanaframeworkResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Seagate Business NAS - Remote Command Execution (Metasploit)
by Metasploit · Mar 4, 2015
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for codeigniter/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update codeigniter/framework to 3.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-8684 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2014-8684 in your dependencies?
Find it across Packagist, including transitive dependencies.