CVE-2018-11385 is a high-severity (CVSS 8.1) CWE-384 vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Session Fixation Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http+7 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. A session fixation vulnerability within the "Guard" login feature may allow an attacker to impersonate a victim towards the web application if the session id value was previously known to the attacker.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.7.0&&< 2.7.48 | 2.7.48composer require symfony/symfony:^2.7.48 |
| 🐘Packagist | symfony/symfony | ≥ 2.8.0&&< 2.8.41 | 2.8.41composer require symfony/symfony:^2.8.41 |
| 🐘Packagist | symfony/symfony | ≥ 3.0.0&&< 3.3.17 | 3.3.17composer require symfony/symfony:^3.3.17 |
| 🐘Packagist | symfony/symfony | ≥ 3.4.0&&< 3.4.11 | 3.4.11composer require symfony/symfony:^3.4.11 |
| 🐘Packagist | symfony/symfony | ≥ 4.0.0&&< 4.0.11 | 4.0.11composer require symfony/symfony:^4.0.11 |
| 🐘Packagist | symfony/security-http | ≥ 2.7.0&&< 2.7.48 | 2.7.48composer require symfony/security-http:^2.7.48 |
Affected Products
debian linuxdebianfedorafedoraprojectsymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.7.48 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11385 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2018-11385 in your dependencies?
Find it across Packagist, including transitive dependencies.