NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-11352 — wallabag

MEDIUM

CVE-2018-11352 is a medium-severity (CVSS 4) Cross-site Scripting (XSS) vulnerability in wallabag/wallabag. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for wallabag/wallabag — see the affected versions and patch details below.

Wallabag cross-site scripting (XSS) vulnerability

Also known asGHSA-gvcw-x64m-pfcj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.81%1.22%0.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘wallabag/wallabag

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistwallabag/wallabag≥ 2.2.3&&< 2.3.32.3.3composer require wallabag/wallabag:^2.3.3

Affected Products

1 product · 1 configurations
Application
wallabagwallabag
≥ 2.2.3 && ≤ 2.3.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wallabag/wallabag, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wallabag/wallabag to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11352 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.
O3 Security · Impact-Aware SCA

Is CVE-2018-11352 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-11352: wallabag XSS — Fixed in 2.3.3