CVE-2023-0737 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in wallabag/wallabag. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for wallabag/wallabag — see the affected versions and patch details below.
CSRF in wallabag/wallabag
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-0737.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
wallabag/wallabagReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
wallabag version 2.5.2 contains a Cross-Site Request Forgery (CSRF) vulnerability that allows attackers to arbitrarily delete user accounts via the /account/delete endpoint. This issue is fixed in version 2.5.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | wallabag/wallabag | all versions | 2.5.4composer require wallabag/wallabag:^2.5.4 |
Affected Products
wallabagwallabagResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wallabag/wallabag, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wallabag/wallabag to 2.5.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-0737 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-0737 in your dependencies?
Find it across Packagist, including transitive dependencies.