NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-11087 — spring-amqp

MEDIUM

CVE-2018-11087 is a medium-severity (CVSS 5.9) CWE-295 vulnerability in org.springframework.amqp:spring-amqp. A fix is available for org.springframework.amqp:spring-amqp — see the affected versions and patch details below.

Moderate severity vulnerability that affects com.rabbitmq:amqp-client and org.springframework.amqp:spring-amqp

Also known asGHSA-w4g2-9hj6-5472
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.05%0.63%1.21%1.79%0.6%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.springframework.amqp:spring-amqp☕org.springframework.amqp:spring-amqp☕com.rabbitmq:amqp-client☕com.rabbitmq:amqp-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of hostname validation. A malicious user that has the ability to intercept traffic would be able to view data in transit.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.amqp:spring-amqp≥ 2.0.0&&< 2.0.62.0.6org.springframework.amqp:spring-amqp:2.0.6
☕Mavenorg.springframework.amqp:spring-amqpall versions1.7.10org.springframework.amqp:spring-amqp:1.7.10
☕Mavencom.rabbitmq:amqp-clientall versions4.8.0com.rabbitmq:amqp-client:4.8.0
☕Mavencom.rabbitmq:amqp-client≥ 5.0.0&&< 5.4.05.4.0com.rabbitmq:amqp-client:5.4.0

Affected Products

2 products · 4 configurations
Application
spring advanced message queuing protocolpivotal_software
≥ 2.0.0 && < 2.0.6
range
Application
rabbitmq java clientvmware
≥ 4.8.1 && < 5.4.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.amqp:spring-amqp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.amqp:spring-amqp to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11087 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of hostname validation. A malicious user that has the ability to intercept traffic would be able to view data in transit.
O3 Security · Impact-Aware SCA

Is CVE-2018-11087 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-11087: spring-amqp — Fixed in 2.0.6