NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2016-2173 — spring-amqp

CRITICAL

CVE-2016-2173 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in org.springframework.amqp:spring-amqp. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework.amqp:spring-amqp — see the affected versions and patch details below.

Improper Input Validation in Spring AMQP

Also known asGHSA-hrp3-8p5w-27gv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
1.71%9.75%17.8%25.8%21.3%6.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.springframework.amqp:spring-amqp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

org.springframework.core.serializer.DefaultDeserializer in Spring AMQP before 1.5.5 allows remote attackers to execute arbitrary code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.amqp:spring-amqpall versions1.5.5org.springframework.amqp:spring-amqp:1.5.5

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
3 versions
222324
Application
spring advanced message queuing protocolvmware
< 1.5.5
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.amqp:spring-amqp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.amqp:spring-amqp to 1.5.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2173 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

org.springframework.core.serializer.DefaultDeserializer in Spring AMQP before 1.5.5 allows remote attackers to execute arbitrary code.
O3 Security · Impact-Aware SCA

Is CVE-2016-2173 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-2173: spring-amqp RCE — Fixed in 1.5.5