NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2018-10406 — osxcollector

HIGHFix: Yelp/osxcollector#160

CVE-2018-10406 is a high-severity (CVSS 7.8) CWE-295 vulnerability in osxcollector. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for osxcollector — see the affected versions and patch details below.

Yelp OSXCollector Improper Certificate Validation

Also known asGHSA-g3cc-pvjj-9xq9PYSEC-2018-95
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍osxcollector

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Yelp OSXCollector. A maliciously crafted Universal/fat binary can evade third-party code signing checks. By not completing full inspection of the Universal/fat binary, the user of the third-party tool will believe that the code is signed by Apple, but the malicious unsigned code will execute.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIosxcollectorall versions1.10pip install --upgrade 'osxcollector==1.10'

Affected Products

1 product · 1 configurations
Application
osxcollectoryelp
< 1.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for osxcollector, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update osxcollector to 1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10406 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue was discovered in Yelp OSXCollector. A maliciously crafted Universal/fat binary can evade third-party code signing checks. By not completing full inspection of the Universal/fat binary, the user of the third-party tool will believe that the code is signed by Apple, but the malicious unsigned code will execute.
O3 Security · Impact-Aware SCA

Is CVE-2018-10406 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-10406: osxcollector — Fixed in 1.10