NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-10366 — user-plugin

MEDIUMFix: rainlab/user-plugin@098c2bc

CVE-2018-10366 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in rainlab/user-plugin. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for rainlab/user-plugin — see the affected versions and patch details below.

User Plugin for October CSS Allows XSS

Also known asGHSA-x5jc-34xf-c24q
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.00%1.06%2.13%3.19%0.5%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘rainlab/user-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the Users (aka Front-end user management) plugin 1.4.5 for October CMS. XSS exists in the name field.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistrainlab/user-pluginall versions1.5.0composer require rainlab/user-plugin:^1.5.0

Affected Products

1 product · 1 configurations
Application
useruser_project
1 version
1.4.5
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44546webappsphp

October CMS User Plugin 1.4.5 - Persistent Cross-Site Scripting

by 0xB9 · Apr 26, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rainlab/user-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rainlab/user-plugin to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10366 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in the Users (aka Front-end user management) plugin 1.4.5 for October CMS. XSS exists in the name field.
O3 Security · Impact-Aware SCA

Is CVE-2018-10366 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-10366: user-plugin XSS — Fixed in 1.5.0