Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-10237 — guava

MEDIUM

CVE-2018-10237 is a medium-severity (CVSS 5.9) CWE-770 vulnerability in com.google.guava:guava. A fix is available for com.google.guava:guava — see the affected versions and patch details below.

Denial of Service in Google Guava

Also known asGHSA-mvr2-9pj6-7w5j
Published
Updated
Affected
6 pkgs
Patched
1 / 6
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.1%probability of exploitation in next 30 days
Lower Risk-0.03%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
2.70%3.69%4.69%5.68%3.3%5.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2018-10237 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 396,257 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

6 pkgs affected
☕com.google.guava:guava☕com.google.guava:guava-jdk5☕com.googlecode.guava-osgi:guava-osgi☕de.mhus.ports:vaadin-shared-deps☕org.hudsonci.lib.guava:guava☕org.sonatype.sisu:sisu-guava

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Unbounded memory allocation in Google Guava 11.0 through 24.x before 24.1.1 allows remote attackers to conduct denial of service attacks against servers that depend on this library and deserialize attacker-provided data, because the AtomicDoubleArray class (when serialized with Java serialization) and the CompoundOrdering class (when serialized with GWT serialization) perform eager allocation without appropriate checks on what a client has sent and whether the data size is reasonable.

Affected Packages

6 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.google.guava:guava≥ 11.0&&< 24.1.1-android24.1.1-androidcom.google.guava:guava:24.1.1-android
☕Mavencom.google.guava:guava-jdk5all versionsNo fix
☕Mavencom.googlecode.guava-osgi:guava-osgiall versionsNo fix
☕Mavende.mhus.ports:vaadin-shared-depsall versionsNo fix
☕Mavenorg.hudsonci.lib.guava:guavaall versionsNo fix
☕Mavenorg.sonatype.sisu:sisu-guavaall versionsNo fix

Affected Products

17 products · 39 configurations
Application
guavagoogle
≥ 11.0 && < 24.1.1
range
Application
banking paymentsoracle
≥ 14.1.0 && ≤ 14.4.0
range
Application
communications ip service activatororacle
2 versions
7.3.07.4.0
Application
customer management and segmentation foundationoracle
1 version
18.0
Application
database serveroracle
3 versions
12.2.0.118c19c
Application
flexcube investor servicingoracle
5 versions
12.1.012.3.012.4.014.0.014.1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.google.guava:guava, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.google.guava:guava to 24.1.1-android or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10237 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Openshift Application Runtimes: Eclipse Vert.x is not exploitable by this flaw, though the vulnerable code is a transient dependency to the product. This issue may be addressed in a future release.

ProductFixed inAdvisory
Red Hat JBoss EAP 7.1guavaRHSA-2018:2425
Red Hat JBoss Enterprise Application Platform 6.4guavaRHSA-2018:2740
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5codehaus-jackson-0:1.9.9-14.redhat_7.1.ep6.el5RHSA-2018:2742
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6codehaus-jackson-0:1.9.9-14.redhat_7.1.ep6.el6RHSA-2018:2743
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7codehaus-jackson-0:1.9.9-14.redhat_7.1.ep6.el7RHSA-2018:2741
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6eap7-activemq-artemis-0:1.5.5.013-1.redhat_1.1.ep7.el6RHSA-2018:2423
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 7eap7-activemq-artemis-0:1.5.5.013-1.redhat_1.1.ep7.el7RHSA-2018:2424
Red Hat JBoss Enterprise Application Platform Continuous DeliveryguavaRHSA-2020:2562

Frequently Asked Questions

Unbounded memory allocation in Google Guava 11.0 through 24.x before 24.1.1 allows remote attackers to conduct denial of service attacks against servers that depend on this library and deserialize attacker-provided data, because the AtomicDoubleArray class (when serialized with Java serialization) and the CompoundOrdering class (when serialized with GWT serialization) perform eager allocation without appropriate checks on what a client has sent and whether the data size is reasonable.
O3 Security · Impact-Aware SCA

Is CVE-2018-10237 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-10237: guava DoS — Fix Available