MCP TypeScript SDK: HTTP server transports and handlers did not limit request body size or JSON-RPC batch lengthGHSA-f897-62hf-6gxq
HIGHFix: modelcontextprotocol/typescript-sdk#2698GHSA-f897-62hf-6gxq is a high-severity (CVSS 7.5) vulnerability in @modelcontextprotocol/sdk. A fix is available for @modelcontextprotocol/sdk — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@modelcontextprotocol/sdknpm@modelcontextprotocol/servernpmDescription
Summary
In affected versions, MCP servers reachable over HTTP put no limit on the size of a POST body or on the number of messages in a JSON-RPC batch. Large requests could exhaust the server's memory, and one long batch could block it from serving anyone else. No credentials were needed, unless your application authenticates requests before they reach the SDK.
Am I affected?
Yes, if clients you do not fully trust can reach your server over Streamable HTTP. A body parser such as express.json() does not protect you, because it does not limit batch length. Servers that only use stdio are not affected.
Affected versions:
@modelcontextprotocol/sdk1.10.0 through 1.30.0@modelcontextprotocol/server2.0.0@modelcontextprotocol/node2.0.0@modelcontextprotocol/hono2.0.0
Fix
Upgrade to:
- 1.x:
@modelcontextprotocol/sdk1.30.1 or later - 2.x:
@modelcontextprotocol/server2.1.0,@modelcontextprotocol/node2.1.0 and@modelcontextprotocol/hono2.0.1 or later. Upgrade every one you have installed.
Bodies over 4 MiB now get 413, and batches over 100 messages get 400. If your clients send larger bodies, raise the new maxRequestBodySize option.
If you cannot upgrade yet, cap request body size in a reverse proxy.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @modelcontextprotocol/sdk | ≥ 1.10.0&&< 1.30.1 | 1.30.1npm install @modelcontextprotocol/sdk@1.30.1 |
| 📦npm | @modelcontextprotocol/server | ≥ 2.0.0&&< 2.1.0 | 2.1.0npm install @modelcontextprotocol/server@2.1.0 |
| 📦npm | @modelcontextprotocol/node | ≥ 2.0.0&&< 2.1.0 | 2.1.0npm install @modelcontextprotocol/node@2.1.0 |
| 📦npm | @modelcontextprotocol/hono | ≥ 2.0.0&&< 2.0.1 | 2.0.1npm install @modelcontextprotocol/hono@2.0.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @modelcontextprotocol/sdk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @modelcontextprotocol/sdk to 1.30.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f897-62hf-6gxq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-f897-62hf-6gxq in your dependencies?
Find it across npm, including transitive dependencies.