CVE-2018-10054 — datomic-free
HIGHCVE-2018-10054 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in com.datomic:datomic-free. EPSS puts its 30-day exploitation probability at 33.7% (98th percentile). A fix is available for com.datomic:datomic-free — see the affected versions and patch details below.
Improper Input Validation in Datomic
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2018-10054.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.datomic:datomic-freeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
H2 1.4.197, as used in Datomic before 0.9.5697 and other products, allows remote code execution because CREATE ALIAS can execute arbitrary Java code. NOTE: the vendor's position is "h2 is not designed to be run outside of a secure environment."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.datomic:datomic-free | all versions | 0.9.5697com.datomic:datomic-free:0.9.5697 |
Affected Products
datomiccognitecth2h2databaseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.datomic:datomic-free, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.datomic:datomic-free to 0.9.5697 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10054 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-10054 in your dependencies?
Find it across Maven, including transitive dependencies.