CVE-2018-1000516 — galaxy-app
MEDIUMCVE-2018-1000516 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in galaxy-app. A fix is available for galaxy-app — see the affected versions and patch details below.
Galaxy cross-site scripting (XSS)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
galaxy-app🐍galaxy-appReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The Galaxy Project Galaxy version v14.10 contains a CWE-79: Improper Neutralization of Input During Web Page Generation vulnerability in Many templates used in the Galaxy server did not properly sanitize user's input, which would allow for cross-site scripting (XSS) attacks. In this form of attack, a malicious person can create a URL which, when opened by a Galaxy user or administrator, would allow the malicious user to execute arbitrary Javascript. that can result in Arbitrary JavaScript code execution. This attack appear to be exploitable via The victim must interact with component on page witch contains injected JavaScript code.. This vulnerability appears to have been fixed in v14.10.1, v15.01.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | galaxy-app | all versions | 14.10.1pip install --upgrade 'galaxy-app==14.10.1' |
| 🐍PyPI | galaxy-app | ≥ 15.0&&< 15.01 | 15.01pip install --upgrade 'galaxy-app==15.01' |
Affected Products
galaxygalaxyprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for galaxy-app, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update galaxy-app to 14.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000516 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2018-1000516 in your dependencies?
Find it across PyPI, including transitive dependencies.