NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1000416 — jobConfigHistory

MEDIUMFix: jenkinsci/job-config-history-plugin@38ea4ed

CVE-2018-1000416 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:jobConfigHistory. A fix is available for org.jenkins-ci.plugins:jobConfigHistory — see the affected versions and patch details below.

Jenkins Job Config History Plugin reflected XSS vulnerability

Also known asGHSA-w3r4-vx9w-f7p7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.89%1.34%0.2%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:jobConfigHistory

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A reflected cross-site scripting vulnerability exists in Jenkins Job Config History Plugin 2.18 and earlier in all Jelly files that shows arbitrary attacker-specified HTML in Jenkins to users with Job/Configure access.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:jobConfigHistoryall versions2.18.1org.jenkins-ci.plugins:jobConfigHistory:2.18.1

Affected Products

1 product · 1 configurations
Application
jobconfighistoryjobconfighistory_project
≤ 2.18
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:jobConfigHistory, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:jobConfigHistory to 2.18.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000416 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A reflected cross-site scripting vulnerability exists in Jenkins Job Config History Plugin 2.18 and earlier in all Jelly files that shows arbitrary attacker-specified HTML in Jenkins to users with Job/Configure access.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000416 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000416: jobConfigHistory XSS — Fixed in 2.18.1