CVE-2018-0571 — basercms
MEDIUMCVE-2018-0571 is a medium-severity (CVSS 4.3) Unrestricted File Upload vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.
baserCMS arbitrary file upload vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
baserproject/basercms🐘baserproject/basercmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
baserCMS (baserCMS 4.1.0.1 and earlier versions, baserCMS 3.0.15 and earlier versions) allows remote attackers with a site operator privilege to upload arbitrary files.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | baserproject/basercms | ≥ 4.0.0&&< 4.1.1 | 4.1.1composer require baserproject/basercms:^4.1.1 |
| 🐘Packagist | baserproject/basercms | all versions | 3.0.16composer require baserproject/basercms:^3.0.16 |
Affected Products
basercmsbasercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update baserproject/basercms to 4.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-0571 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is CVE-2018-0571 in your dependencies?
Find it across Packagist, including transitive dependencies.