CVE-2017-9516 — cms
MEDIUMCVE-2017-9516 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in craftcms/cms. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for craftcms/cms — see the affected versions and patch details below.
Craft CMS XSS Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
craftcms/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Craft CMS before 2.6.2982 allows for a potential XSS attack vector by uploading a malicious SVG file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | craftcms/cms | all versions | 2.6.2982composer require craftcms/cms:^2.6.2982 |
Affected Products
craft cmscraftcmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Craft CMS 2.6 - Cross-Site Scripting
by Ahsan Tahir · Jun 8, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update craftcms/cms to 2.6.2982 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-9516 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-9516 in your dependencies?
Find it across Packagist, including transitive dependencies.