CVE-2017-8827 is a critical-severity (CVSS 9.1) Improper Authentication vulnerability in genix/cms. A fix is available for genix/cms — see the affected versions and patch details below.
GeniXCMS Arbitrary User Password Reset Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
genix/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
forgotpassword.php in GeniXCMS 1.0.2 lacks a rate limit, which might allow remote attackers to cause a denial of service (login inability) or possibly conduct Arbitrary User Password Reset attacks via a series of requests.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | genix/cms | all versions | 1.1.2composer require genix/cms:^1.1.2 |
Affected Products
genixcmsgenixcmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for genix/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update genix/cms to 1.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8827 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2017-8827 in your dependencies?
Find it across Packagist, including transitive dependencies.