CVE-2017-8780 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in genix/cms. A fix is available for genix/cms — see the affected versions and patch details below.
GeniXCMS Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
genix/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
GeniXCMS 1.0.2 has XSS triggered by a comment that is mishandled during a publish operation by an administrator, as demonstrated by a malformed P element.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | genix/cms | all versions | 1.1.0composer require genix/cms:^1.1.0 |
Affected Products
genixcmsgenixcmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for genix/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update genix/cms to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8780 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-8780 in your dependencies?
Find it across Packagist, including transitive dependencies.