NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-8385 — cms

MEDIUMFix: craftcms/cms@38c594b

CVE-2017-8385 is a medium-severity (CVSS 5.3) CWE-640 vulnerability in craftcms/cms. A fix is available for craftcms/cms — see the affected versions and patch details below.

Craft CMS subject to URL forgery

Also known asGHSA-j27g-r58q-624w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.98%1.46%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘craftcms/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Craft CMS before 2.6.2976 does not prevent modification of the URL in a forgot-password email message.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcraftcms/cmsall versions2.6.2976composer require craftcms/cms:^2.6.2976

Affected Products

1 product · 1 configurations
Application
craft cmscraftcms
≤ 2.6.2974
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update craftcms/cms to 2.6.2976 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8385 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Craft CMS before 2.6.2976 does not prevent modification of the URL in a forgot-password email message.
O3 Security · Impact-Aware SCA

Is CVE-2017-8385 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-8385: cms — Fixed in 2.6.2976