NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-8052 — cms

MEDIUMFix: craftcms/cms@f7e5701

CVE-2017-8052 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in craftcms/cms. A fix is available for craftcms/cms — see the affected versions and patch details below.

Craft CMS XSS Vulnerability

Also known asGHSA-xv5f-2997-qhrq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.89%1.33%0.4%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘craftcms/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Craft CMS before 2.6.2974 allows XSS attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcraftcms/cmsall versions2.6.2974composer require craftcms/cms:^2.6.2974

Affected Products

1 product · 1 configurations
Application
craft cmscraftcms
≤ 2.6.2973
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update craftcms/cms to 2.6.2974 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8052 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Craft CMS before 2.6.2974 allows XSS attacks.
O3 Security · Impact-Aware SCA

Is CVE-2017-8052 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-8052: cms XSS — Fixed in 2.6.2974