CVE-2017-7662 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in org.apache.cxf.fediz:fediz-oidc. A fix is available for org.apache.cxf.fediz:fediz-oidc — see the affected versions and patch details below.
Cross-Site Request Forgery in Apache CXF Fediz
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.cxf.fediz:fediz-oidcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache CXF Fediz ships with an OpenId Connect (OIDC) service which has a Client Registration Service, which is a simple web application that allows clients to be created, deleted, etc. A CSRF (Cross Style Request Forgery) style vulnerability has been found in this web application in Apache CXF Fediz prior to 1.4.0 and 1.3.2, meaning that a malicious web application could create new clients, or reset secrets, etc, after the admin user has logged on to the client registration service and the session is still active.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.cxf.fediz:fediz-oidc | all versions | 1.3.2org.apache.cxf.fediz:fediz-oidc:1.3.2 |
Affected Products
cxf fedizapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cxf.fediz:fediz-oidc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.cxf.fediz:fediz-oidc to 1.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7662 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-7662 in your dependencies?
Find it across Maven, including transitive dependencies.