NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-7620 — mantisbt

MEDIUMFix: mantisbt/mantisbt@2d2309a

CVE-2017-7620 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in mantisbt/mantisbt. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for mantisbt/mantisbt — see the affected versions and patch details below.

MantisBT vulnerable to CSRF and Open Redirect attacks

Also known asGHSA-9x76-mp7r-2xc5
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
3 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.62%1.24%1.86%0.3%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘mantisbt/mantisbt🐘mantisbt/mantisbt🐘mantisbt/mantisbt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

MantisBT before 1.3.11, 2.x before 2.3.3, and 2.4.x before 2.4.1 omits a backslash check in string_api.php and consequently has conflicting interpretations of an initial / substring as introducing either a local pathname or a remote hostname, which leads to (1) arbitrary Permalink Injection via CSRF attacks on a permalink_page.php?url= URI and (2) an open redirect via a login_page.php?return= URI.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmantisbt/mantisbtall versions1.3.11composer require mantisbt/mantisbt:^1.3.11
🐘Packagistmantisbt/mantisbt≥ 2.0.0&&< 2.3.32.3.3composer require mantisbt/mantisbt:^2.3.3
🐘Packagistmantisbt/mantisbt≥ 2.4.0&&< 2.4.12.4.1composer require mantisbt/mantisbt:^2.4.1

Affected Products

1 product · 11 configurations
Application
mantisbtmantisbt
≤ 1.3.10
10 versions
2.0.02.0.12.1.02.1.12.1.22.2.02.2.22.2.32.2.42.4.0
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-42043webappsphp

Mantis Bug Tracker 1.3.10/2.3.0 - Cross-Site Request Forgery

by hyp3rlinx · May 20, 2017

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mantisbt/mantisbt to 1.3.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7620 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

MantisBT before 1.3.11, 2.x before 2.3.3, and 2.4.x before 2.4.1 omits a backslash check in string_api.php and consequently has conflicting interpretations of an initial \/ substring as introducing either a local pathname or a remote hostname, which leads to (1) arbitrary Permalink Injection via CSRF attacks on a permalink_page.php?url= URI and (2) an open redirect via a login_page.php?return= URI.
O3 Security · Impact-Aware SCA

Is CVE-2017-7620 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-7620: mantisbt CSRF — Fixed in 1.3.11