CVE-2017-7536 is a high-severity (CVSS 7) CWE-592 vulnerability in org.hibernate:hibernate-validator. A fix is available for org.hibernate:hibernate-validator — see the affected versions and patch details below.
Privilege Escalation in Hibernate Validator
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.hibernate:hibernate-validator☕org.hibernate:hibernate-validator☕org.hibernate:hibernate-validatorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Hibernate Validator 5.2.x before 5.2.5.Final, 5.3.x before 5.3.6.Final, and 5.4.x before 5.4.2.Final, it was found that when the security manager's reflective permissions, which allows it to access the private members of the class, are granted to Hibernate Validator, a potential privilege escalation can occur. By allowing the calling code to access those private members without the permission an attacker may be able to validate an invalid instance and access the private member value via ConstraintViolation#getInvalidValue().
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.hibernate:hibernate-validator | ≥ 5.2.0&&< 5.2.5.Final | 5.2.5.Finalorg.hibernate:hibernate-validator:5.2.5.Final |
| ☕Maven | org.hibernate:hibernate-validator | ≥ 5.3.0&&< 5.3.6.Final | 5.3.6.Finalorg.hibernate:hibernate-validator:5.3.6.Final |
| ☕Maven | org.hibernate:hibernate-validator | ≥ 5.4.0&&< 5.4.2.Final | 5.4.2.Finalorg.hibernate:hibernate-validator:5.4.2.Final |
Affected Products
hibernate validatorredhatjboss enterprise application platformredhatsatelliteredhatsatellite capsuleredhatvirtualizationredhatvirtualization hostredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.hibernate:hibernate-validator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.hibernate:hibernate-validator to 5.2.5.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7536 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.3 | hibernate-validator | RHSA-2018:3817 |
| Red Hat JBoss EAP 7 | see advisory | RHSA-2017:2810 |
| Red Hat JBoss EAP 7 | see advisory | RHSA-2017:3456 |
| Red Hat JBoss Enterprise Application Platform 6.4 | hibernate-validator | RHSA-2018:2740 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 | codehaus-jackson-0:1.9.9-14.redhat_7.1.ep6.el5 | RHSA-2018:2742 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | codehaus-jackson-0:1.9.9-14.redhat_7.1.ep6.el6 | RHSA-2018:2743 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 | codehaus-jackson-0:1.9.9-14.redhat_7.1.ep6.el7 | RHSA-2018:2741 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-artemis-native-0:1.1.0-13.redhat_4.ep7.el6 | RHSA-2017:2809 |
Frequently Asked Questions
Is CVE-2017-7536 in your dependencies?
Find it across Maven, including transitive dependencies.