CVE-2014-3558 — hibernate-validator
Fix: hibernate/hibernate-validator@2c95d4eCVE-2014-3558 is a CWE-264 vulnerability in org.hibernate:hibernate-validator. A fix is available for org.hibernate:hibernate-validator — see the affected versions and patch details below.
Improper Authentication in Hibernate Validator
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.hibernate:hibernate-validator☕org.hibernate:hibernate-validator☕org.hibernate:hibernate-validatorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
ReflectionHelper (org.hibernate.validator.util.ReflectionHelper) in Hibernate Validator 4.1.0 before 4.2.1, 4.3.x before 4.3.2, and 5.x before 5.1.2 allows attackers to bypass Java Security Manager (JSM) restrictions and execute restricted reflection calls via a crafted application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.hibernate:hibernate-validator | ≥ 4.1.0&&< 4.2.1 | 4.2.1org.hibernate:hibernate-validator:4.2.1 |
| ☕Maven | org.hibernate:hibernate-validator | ≥ 4.3.0&&< 4.3.2 | 4.3.2org.hibernate:hibernate-validator:4.3.2 |
| ☕Maven | org.hibernate:hibernate-validator | ≥ 5.0.0&&< 5.1.2 | 5.1.2org.hibernate:hibernate-validator:5.1.2 |
Affected Products
hibernate validatorredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.hibernate:hibernate-validator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.hibernate:hibernate-validator to 4.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3558 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss BPMS 6.0 | hibernate-validator | RHSA-2015:0234 |
| Red Hat JBoss BRMS 6.0 | hibernate-validator | RHSA-2015:0235 |
| Red Hat JBoss Enterprise Application Platform 6.3 | see advisory | RHSA-2014:1288 |
| Red Hat JBoss Enterprise Application Platform 6.3 for RHEL 5 | glassfish-jaxb-eap6-0:2.2.5-22.redhat_9.1.ep6.el5 | RHSA-2014:1286 |
| Red Hat JBoss Enterprise Application Platform 6.3 for RHEL 6 | glassfish-jaxb-eap6-0:2.2.5-22.redhat_9.1.ep6.el6 | RHSA-2014:1285 |
| Red Hat JBoss Enterprise Application Platform 6.3 for RHEL 7 | glassfish-jaxb-eap6-0:2.2.5-22.redhat_9.1.ep6.el7 | RHSA-2014:1287 |
| Red Hat JBoss Fuse Service Works 6.0 | hibernate-validator | RHSA-2015:0720 |
| Red Hat JBoss Web Framework Kit 2.7 | hibernate-validator | RHSA-2015:0125 |
Frequently Asked Questions
Is CVE-2014-3558 in your dependencies?
Find it across Maven, including transitive dependencies.