CVE-2017-6929 — core
MEDIUMCVE-2017-6929 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal cross site scripting vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 7.0&&< 7.57 | 7.57composer require drupal/core:^7.57 |
| 🐘Packagist | drupal/core | ≥ 8.0&&< 8.4.0 | 8.4.0composer require drupal/core:^8.4.0 |
| 🐘Packagist | drupal/drupal | ≥ 8.0&&< 8.4.0 | 8.4.0composer require drupal/drupal:^8.4.0 |
| 🐘Packagist | drupal/drupal | ≥ 7.0&&< 7.57 | 7.57composer require drupal/drupal:^7.57 |
Affected Products
debian linuxdebiandrupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 7.57 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6929 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-6929 in your dependencies?
Find it across Packagist, including transitive dependencies.