NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-6927 — core

MEDIUM

CVE-2017-6927 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Drupal cross-site scripting vulnerability

Also known asGHSA-585j-5449-mf5m
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.89%1.33%1.77%2.21%1.4%1.6%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 8.4.0&&< 8.4.58.4.5composer require drupal/core:^8.4.5
🐘Packagistdrupal/core≥ 7.0&&< 7.577.57composer require drupal/core:^7.57
🐘Packagistdrupal/drupal≥ 8.4.0&&< 8.4.58.4.5composer require drupal/drupal:^8.4.5
🐘Packagistdrupal/drupal≥ 7.0&&< 7.577.57composer require drupal/drupal:^7.57

Affected Products

2 products · 5 configurations
OS
debian linuxdebian
3 versions
7.08.09.0
Application
drupaldrupal
≥ 8.4.0 && < 8.4.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 8.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6927 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.
O3 Security · Impact-Aware SCA

Is CVE-2017-6927 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-6927: core XSS — Fixed in 8.4.5