NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2017-6920 — core

CRITICAL

CVE-2017-6920 is a critical-severity (CVSS 9.8) CWE-19 vulnerability in drupal/core. EPSS puts its 30-day exploitation probability at 20.2% (97th percentile). A fix is available for drupal/core — see the affected versions and patch details below.

Drupal PECL YAML parser unsafe object handling

Also known asGHSA-9c24-g32g-35rj
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
20.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
6.47%31.0%55.4%79.9%66.1%20.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘drupal/core🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 8.0&&< 8.3.48.3.4composer require drupal/core:^8.3.4
🐘Packagistdrupal/drupal≥ 8.0&&< 8.3.48.3.4composer require drupal/drupal:^8.3.4

Affected Products

1 product · 1 configurations
Application
drupaldrupal
≥ 8.0.0 && < 8.3.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 8.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6920 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.
O3 Security · Impact-Aware SCA

Is CVE-2017-6920 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-6920: core RCE — Fixed in 8.3.4