NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-6484 — inter-mediator

MEDIUM

CVE-2017-6484 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in inter-mediator/inter-mediator. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for inter-mediator/inter-mediator — see the affected versions and patch details below.

INTER-Mediator Cross-Site Scripting (XSS)

Also known asGHSA-w969-pq6x-267j
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.80%1.20%0.3%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘inter-mediator/inter-mediator

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple Cross-Site Scripting (XSS) issues were discovered in INTER-Mediator 5.5. The vulnerabilities exist due to insufficient filtration of user-supplied data (c and cred) passed to the "INTER-Mediator-master/Auth_Support/PasswordReset/resetpassword.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistinter-mediator/inter-mediator≥ 5.5&&< 5.65.6composer require inter-mediator/inter-mediator:^5.6

Affected Products

1 product · 1 configurations
Application
inter-mediatorinter-mediator
1 version
5.5
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for inter-mediator/inter-mediator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update inter-mediator/inter-mediator to 5.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6484 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple Cross-Site Scripting (XSS) issues were discovered in INTER-Mediator 5.5. The vulnerabilities exist due to insufficient filtration of user-supplied data (c and cred) passed to the "INTER-Mediator-master/Auth_Support/PasswordReset/resetpassword.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
O3 Security · Impact-Aware SCA

Is CVE-2017-6484 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-6484: inter-mediator XSS — Fixed in 5.6