CVE-2017-6377 — core
HIGHCVE-2017-6377 is a high-severity (CVSS 7.5) CWE-863 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal editor module incorrectly checks access to inline private files
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
When adding a private file via the editor in Drupal 8.2.x before 8.2.7, the editor will not correctly check access for the file being attached, resulting in an access bypass.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.2.0&&< 8.2.7 | 8.2.7composer require drupal/core:^8.2.7 |
| 🐘Packagist | drupal/drupal | ≥ 8.2.0&&< 8.2.7 | 8.2.7composer require drupal/drupal:^8.2.7 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6377 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2017-6377 in your dependencies?
Find it across Packagist, including transitive dependencies.