NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-17837 — jsf-module-project

MEDIUMFix: apache/deltaspike@4e25023

CVE-2017-17837 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.deltaspike.modules:jsf-module-project. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.deltaspike.modules:jsf-module-project — see the affected versions and patch details below.

Cross-site Scripting in Apache DeltaSpike

Also known asGHSA-4q23-g7mf-xp98
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
1.02%2.44%3.85%5.27%1.8%4.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.deltaspike.modules:jsf-module-project

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The Apache DeltaSpike-JSF 1.8.0 module has a XSS injection leak in the windowId handling. The default size of the windowId get's cut off after 10 characters (by default), so the impact might be limited. A fix got applied and released in Apache deltaspike-1.8.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.deltaspike.modules:jsf-module-projectall versions1.8.1org.apache.deltaspike.modules:jsf-module-project:1.8.1

Affected Products

1 product · 1 configurations
Application
deltaspikeapache
1 version
1.8.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.deltaspike.modules:jsf-module-project, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.deltaspike.modules:jsf-module-project to 1.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-17837 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The Apache DeltaSpike-JSF 1.8.0 module has a XSS injection leak in the windowId handling. The default size of the windowId get's cut off after 10 characters (by default), so the impact might be limited. A fix got applied and released in Apache deltaspike-1.8.1.
O3 Security · Impact-Aware SCA

Is CVE-2017-17837 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-17837: jsf-module-project XSS — Fixed in 1.8.1