CVE-2017-16654 is a high-severity (CVSS 7.5) Path Traversal vulnerability in symfony/intl. A fix is available for symfony/intl — see the affected versions and patch details below.
Symfony Directory Traversal
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/intl🐘symfony/intl🐘symfony/intl🐘symfony/intl🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfonyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The Intl component includes various bundle readers that are used to read resource bundles from the local filesystem. The read() methods of these classes use a path and a locale to determine the language bundle to retrieve. The locale argument value is commonly retrieved from untrusted user input (like a URL parameter). An attacker can use this argument to navigate to arbitrary directories via the dot-dot-slash attack, aka Directory Traversal.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/intl | ≥ 2.7.0&&< 2.7.38 | 2.7.38composer require symfony/intl:^2.7.38 |
| 🐘Packagist | symfony/intl | ≥ 2.8.0&&< 2.8.31 | 2.8.31composer require symfony/intl:^2.8.31 |
| 🐘Packagist | symfony/intl | ≥ 3.0.0&&< 3.2.14 | 3.2.14composer require symfony/intl:^3.2.14 |
| 🐘Packagist | symfony/intl | ≥ 3.3.0&&< 3.3.13 | 3.3.13composer require symfony/intl:^3.3.13 |
| 🐘Packagist | symfony/symfony | ≥ 2.7.0&&< 2.7.38 | 2.7.38composer require symfony/symfony:^2.7.38 |
| 🐘Packagist | symfony/symfony | ≥ 2.8.0&&< 2.8.31 | 2.8.31composer require symfony/symfony:^2.8.31 |
Affected Products
debian linuxdebiansymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/intl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/intl to 2.7.38 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16654 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2017-16654 in your dependencies?
Find it across Packagist, including transitive dependencies.