CVE-2017-16652 — symfony
MEDIUMCVE-2017-16652 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Open Redirect
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http🐘symfony/security-http+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Symfony 2.7.x before 2.7.38, 2.8.x before 2.8.31, 3.2.x before 3.2.14, and 3.3.x before 3.3.13. DefaultAuthenticationSuccessHandler or DefaultAuthenticationFailureHandler takes the content of the _target_path parameter and generates a redirect response, but no check is performed on the path, which could be an absolute URL to an external domain. This Open redirect vulnerability can be exploited for example to mount effective phishing attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.7.0&&< 2.7.38 | 2.7.38composer require symfony/symfony:^2.7.38 |
| 🐘Packagist | symfony/symfony | ≥ 2.8.0&&< 2.8.31 | 2.8.31composer require symfony/symfony:^2.8.31 |
| 🐘Packagist | symfony/symfony | ≥ 3.2.0&&< 3.2.14 | 3.2.14composer require symfony/symfony:^3.2.14 |
| 🐘Packagist | symfony/symfony | ≥ 3.3.0&&< 3.3.13 | 3.3.13composer require symfony/symfony:^3.3.13 |
| 🐘Packagist | symfony/security-http | ≥ 2.7.0&&< 2.7.38 | 2.7.38composer require symfony/security-http:^2.7.38 |
| 🐘Packagist | symfony/security-http | ≥ 2.8.0&&< 2.8.31 | 2.8.31composer require symfony/security-http:^2.8.31 |
Affected Products
debian linuxdebiansymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.7.38 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16652 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is CVE-2017-16652 in your dependencies?
Find it across Packagist, including transitive dependencies.