CVE-2017-16244 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in october/october. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for october/october — see the affected versions and patch details below.
October CMS CSRF
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/octoberReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-Site Request Forgery exists in OctoberCMS 1.0.426 (aka Build 426) due to improper validation of CSRF tokens for postback handling, allowing an attacker to successfully take over the victim's account. The attack bypasses a protection mechanism involving X-CSRF headers and CSRF tokens via a certain _handler postback variable.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/october | all versions | 1.0.427composer require october/october:^1.0.427 |
Affected Products
octoberoctobercmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
OctoberCMS 1.0.426 (Build 426) - Cross-Site Request Forgery
by Zain Sabahat · Nov 1, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/october, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/october to 1.0.427 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16244 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-16244 in your dependencies?
Find it across Packagist, including transitive dependencies.