NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-15363 — restler

HIGH

CVE-2017-15363 is a high-severity (CVSS 7.5) Path Traversal vulnerability in aoe/restler. EPSS puts its 30-day exploitation probability at 15.3% (97th percentile). A fix is available for aoe/restler — see the affected versions and patch details below.

Luracast Restler directory traversal vulnerability

Also known asGHSA-rvmg-xc29-rvxf
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
15.3%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%29.4%58.9%88.3%61.0%15.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘aoe/restler🐘luracast/restler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Directory traversal vulnerability in public/examples/resources/getsource.php in Luracast Restler through 3.0.0, as used in the restler extension before 1.7.1 for TYPO3, allows remote attackers to read arbitrary files via the file parameter.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistaoe/restlerall versions1.7.1composer require aoe/restler:^1.7.1
🐘Packagistluracast/restlerall versions3.1.0composer require luracast/restler:^3.1.0

Affected Products

1 product · 2 configurations
Application
restlerluracast
< 3.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aoe/restler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aoe/restler to 1.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15363 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2017-15363

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2017-15363 -u https://target
Template
Luracast Restler 3.0.1 via TYPO3 Restler 1.7.1 - Local File Inclusion
Severity
high
Impact
The vulnerability allows an attacker to include local files, potentially leading to unauthorized access or code execution.
Remediation
Update to the latest version of Restler and TYPO3 to fix the vulnerability.

Template by ProjectDiscovery nuclei-templates (0x_Akoko), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Directory traversal vulnerability in public/examples/resources/getsource.php in Luracast Restler through 3.0.0, as used in the restler extension before 1.7.1 for TYPO3, allows remote attackers to read arbitrary files via the file parameter.
O3 Security · Impact-Aware SCA

Is CVE-2017-15363 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-15363: restler Path Traversal — Fixed in 1.7.1