NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
MEDIUM severity

CVE-2017-15279 — UmbracoCMS.Web

MEDIUMFix: umbraco/Umbraco-CMS@fe2b86b

CVE-2017-15279 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in UmbracoCMS.Web. A fix is available for UmbracoCMS.Web — see the affected versions and patch details below.

Umbraco CMS vulnerable to stored XSS

Also known asGHSA-xj94-rgf9-cq37
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.34%0.2%0.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
.NETUmbracoCMS.Web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Umbraco CMS before 7.7.3 allows remote attackers to inject arbitrary web script or HTML via the "page name" (aka nodename) parameter during the creation of a new page, related to Umbraco.Web.UI/umbraco/dialogs/Publish.aspx.cs and Umbraco.Web/umbraco.presentation/umbraco/dialogs/notifications.aspx.cs.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetUmbracoCMS.Weball versions7.7.3dotnet add package UmbracoCMS.Web --version 7.7.3

Affected Products

1 product · 1 configurations
Application
umbraco cmsumbraco
≤ 7.7.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for UmbracoCMS.Web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update UmbracoCMS.Web to 7.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15279 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Umbraco CMS before 7.7.3 allows remote attackers to inject arbitrary web script or HTML via the "page name" (aka nodename) parameter during the creation of a new page, related to Umbraco.Web.UI/umbraco/dialogs/Publish.aspx.cs and Umbraco.Web/umbraco.presentation/umbraco/dialogs/notifications.aspx.cs.
O3 Security · Impact-Aware SCA

Is CVE-2017-15279 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2017-15279: UmbracoCMS.Web XSS — Fixed in 7.7.3