NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-14735 — antisamy

MEDIUM

CVE-2017-14735 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.owasp.antisamy:antisamy. A fix is available for org.owasp.antisamy:antisamy — see the affected versions and patch details below.

OWASP AntiSamy Cross-site Scripting vulnerability

Also known asGHSA-q44v-xc3g-v7jq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.18%0.84%1.50%2.16%0.7%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.owasp.antisamy:antisamy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of : to construct a javascript: URL.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.owasp.antisamy:antisamyall versions1.5.7org.owasp.antisamy:antisamy:1.5.7

Affected Products

1 product · 1 configurations
Application
antisamyantisamy_project
< 1.5.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.owasp.antisamy:antisamy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.owasp.antisamy:antisamy to 1.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-14735 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of &colon; to construct a javascript: URL.
O3 Security · Impact-Aware SCA

Is CVE-2017-14735 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-14735: antisamy XSS — Fixed in 1.5.7