NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-12867 — simplesamlphp

MEDIUMFix: simplesamlphp/simplesamlphp@608f24c

CVE-2017-12867 is a medium-severity (CVSS 5.9) CWE-613 vulnerability in simplesamlphp/simplesamlphp. A fix is available for simplesamlphp/simplesamlphp — see the affected versions and patch details below.

SimpleSAMLphp Invalid token creation and validation

Also known asGHSA-597c-mh7m-48v7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.17%1.75%0.2%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘simplesamlphp/simplesamlphp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsimplesamlphp/simplesamlphp≥ 1.14.0&&< 1.14.151.14.15composer require simplesamlphp/simplesamlphp:^1.14.15

Affected Products

1 product · 1 configurations
Application
simplesamlphpsimplesamlphp
≤ 1.14.14
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simplesamlphp/simplesamlphp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update simplesamlphp/simplesamlphp to 1.14.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12867 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
O3 Security · Impact-Aware SCA

Is CVE-2017-12867 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-12867: simplesamlphp — Fixed in 1.14.15