NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-12871 — simplesamlphp

MEDIUMFix: simplesamlphp/simplesamlphp@77df6a9

CVE-2017-12871 is a medium-severity (CVSS 5.9) CWE-326 vulnerability in simplesamlphp/simplesamlphp. A fix is available for simplesamlphp/simplesamlphp — see the affected versions and patch details below.

SimpleSAMLphp Incorrect IV generation for encryption

Also known asGHSA-ww3w-592j-5qrw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘simplesamlphp/simplesamlphp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsimplesamlphp/simplesamlphp≥ 1.14.0&&< 1.14.121.14.12composer require simplesamlphp/simplesamlphp:^1.14.12

Affected Products

1 product · 12 configurations
Application
simplesamlphpsimplesamlphp
12 versions
1.14.01.14.11.14.21.14.31.14.41.14.51.14.61.14.71.14.81.14.91.14.101.14.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simplesamlphp/simplesamlphp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update simplesamlphp/simplesamlphp to 1.14.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12871 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).
O3 Security · Impact-Aware SCA

Is CVE-2017-12871 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-12871: simplesamlphp — Fixed in 1.14.12